Symptom
- New hires initiated manually (via Admin Center > Add New Hire to Onboarding) are not visible in the Onboarding Dashboard.
- Multiple processes remain in an "Unfinished" status in Admin Center > BPE: Monitor Processes, with a Job ID associated.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Go to Admin Center > Add New Hire to Onboarding
- Enter the new hire's Basic Information
- Initiate Onboarding
- Results:
- The new hire is not visible in the Onboarding Dashboard.
- In Admin Center > BPE: Monitor Processes, multiple processes remains "Unfinished", with a Job ID associated.
Cause
The issue occurs when a BPE Service User is not added to the OnboardingBPEServiceUser permission group or is inactive in the system.
@SAP Support: Please refer to the internal memo for sample back-end logs related to this issue.
Resolution
Verification:
- Verify that a valid BPE Service User is added to the OnboardingBPEServiceUser permission group under Admin Center > Manage Permission Groups.
If no user is assigned, complete the following steps:
- Navigate to Admin Center > Manage Permission Groups
- Add a valid BPE Service User to the OnboardingBPEServiceUser group.
- Go to Admin Center > Update Process Flow for Onboarding.
- In the "Select Service User" field, select the BPE Service User added to the permission group.
- Click Update
- Navigate to Admin Center > BPE: Manage Process Tasks.
- Restart all unfinished tasks.
See Also
Keywords
onboarding, OnboardingBPEServiceUser, service, user, Failed, to, initialize, job, context, for, AbstractJobContextJanitor, permission, groups, Specified, service, task, user, identity, doesn't, exist , KBA , LOD-SF-OBX-DBD , Dashboard , LOD-SF-OBX-BPE , BPE Process Flow , Problem
Product
SAP SuccessFactors Onboarding all versions
SAP Knowledge Base Article - Public