SAP Knowledge Base Article - Public

3715052 - Custom Email is Not Triggered When Personal Data Collection Step is In Progress - Onboarding

Symptom

  • Custom email does not trigger when the Personal Data Collection step is started for candidates.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Create a custom email notification.
  2. Assign it to the Process Object to trigger the email when the Personal Data Collection step is started.
  3. Initiate the Personal Data Collection step for a candidate.
  4. Observe that the email notification is not triggered.

Cause

  • The condition in the rule is incorrectly configured. The condition is set as "Original Record. Process Tasks ≡ Process Task Status is equal to In Progress" instead of "Process. Process Tasks ≡ Process Task Status is equal to In Progress".

Resolution

  1. Update the condition in the rule to match the correct format as per the guide: "Process. Process Tasks ≡ Process Task Status is equal to In Progress".
  2. Restart the onboarding process to trigger the email.

For more details, refer to the KBA: 3342669 - Email Notification When the New Hire Data Review step is In Progress?

See Also

Creating a Business Rule to Trigger an Email Notification When the New Hire Data Review Step is In Progress

KBA: 3342669 - Email Notification When the New Hire Data Review step is In Progress?

Keywords

email, notification, custom email, personal data collection, PDC, process object, email trigger, rule configuration, process tasks, process task status, onboarding email, OBX, rule condition, Original Record, Process Task Status , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding all versions