SAP Knowledge Base Article - Public

3715183 - iOS Mobile App: Error Message When Saving Goal in Performance Form

Symptom

When creating a Goal within a PM form using the Mobile App on iOS, users intermittently receive the following error message upon saving: "Error – Please try again."

Despite the error message, after exiting and reopening the performance form, the Goal is typically saved successfully.

This behavior is reported only on the iOS mobile application and does not occur on the Android mobile application.

Environment

  • SAP SuccessFactors Mobile
  • SAP SuccessFactors Performance Management
  • SAP SuccessFactors Goal Management

Reproducing the Issue

  1. Log in to the SAP SuccessFactors Mobile App (iOS).

  2. Open a Performance Management form.

  3. Add a Development Goal to the form.

  4. Save the goal.

  5. Observe the error message:

    • "Error – Please try again."

  6. Exit the performance form.

  7. Reopen the same performance form.

  8. Observe that the Development Goal has been saved despite the previous error message.

Cause

This is a Known Issue.

Resolution

The fix for this issue is planned to be deployed on 1H 2026 release (b2605).

For release timelines, please review SAP SuccessFactors Product Release & Road Map Information.

See Also

Keywords

KI2H2025, Goal error, Apple, iOS, goal on performance form, creation error, create goal, mobile app, development goal, performance goal, PMU-25484 , KBA , LOD-SF-PM-MOB , Mobile Interface , Known Error

Product

SAP SuccessFactors Performance & Goals 2511