Symptom
Username for Temporary Internal Assignment/Higher Duty Assignment is generated same as userid instead of the expected format(username-n) where username comes from the Nominal Assignment.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Navigate to an employee profile.
- Select "Take Action" -> Add Higher Duty Assignment
- Fill in the required details and submit.
- Observe that the username is generated as a numeric series identical to the user ID, rather than the expected format (username-n).
Cause
Centralized services became universal for Higher Duties after the 2H 2025 release, leading to changes in the framework for username generation.
Resolution
- Engineering team has temporarily fixed the issue via patch which is scheduled on 24th Feb in Preview system and 26th Feb in Production.
- Please bookmark and monitor this KBA for further updates on the resolution.
Workaround
Perform a manual username update via basic import to align with the expected format.
See Also
Keywords
higher duty assignment,INC19246242 ,username generation, ECT-266588,centralized services, numeric username, username-n format, downstream integration impact, SAP SuccessFactors, employee central, 2H 2025 release, manual import, code correction request,PTCH-49177,username, user id, id, ID, USER ID, USER, numbers,database, sequence,HDP, HD,higher duty, duty, temporal,assignment , KBA , LOD-SF-EC-HDP , Higher Duties & Public Sector , LOD-SF-EC , Employee Central , Known Error
SAP Knowledge Base Article - Public