SAP Knowledge Base Article - Public

3715337 - Filter in Advanced Search not Working as Expected in Cost and Revenue work center.

Symptom

  • Filter not working as expected in the advanced search for product category in the "Customer Contract Items" view within the "Cost and Revenue" work center.
  • No results appear when entering a product category, such as "ABC", in the advanced filter for contract line items. (ABC represents the Product Category Code)

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Cost and Revenue work center.
  2. Select the view "Sales Document Items".
  3. Choose the dropdown view "Customer Contract Items".
  4. Run the query to display the data in the table.
  5. Select Adaptation mode.
  6. Add the column "Product Category" to the table view.
  7. Select Advanced Filter.
  8. Enter "ABC" in the filter for Product Category.
  9. Observe that no results appear.

Cause

Incorrect OWL screen (SADL_OWL) is being called in the UI for the work center view, causing sorting and filtering issues.

Resolution

  1. Access the Business Configuration work center.
  2. Select Overview and click on "All Current Projects".
  3. Choose the First Implementation Project and navigate to Scope.
  4. Click "Next" to proceed to the Questions section.
  5. Expand "System Management" under the section "Support".
  6. Select "User Interface List Mode".
  7. Uncheck "In Scope SADL".
  8. Check "In Scope CLASSIC_OWL (Classic Mode)".
  9. Save the changes.
  10. Verify that sorting and filtering functions now work correctly in the view.

Keywords

filter issue, advanced search, product category, cost and revenue, customer contract items, sorting issue, filtering issue, SADL_OWL, CLASSIC_OWL, adaptation mode, business configuration, user interface list mode, SAP Business ByDesign , KBA , SRD-FIN-COR , Cost & Revenue , Problem

Product

SAP Business ByDesign all versions