SAP Knowledge Base Article - Public

3715894 - Error with rehire using previously used email address in manual onboarding - Onboarding

Symptom

Error message: "There's already a user with username or email ID X in the system. Enter a different email ID and try again."

Environment

SAP SuccessFactors Onboarding 

Reproducing the Issue

  1. Navigate to "Add new hire to onboarding" in the Admin Center.
  2. Fill all required fields, including the same email address used in the previous profile.
  3. Observe the error message: "There's already a user with username or email ID X in the system. Enter a different email ID and try again."

Cause

Since the email address is used as the username, it is not possible to rehire or initiate a new hire with the same email address.

Resolution

  1. Even though your proposal involves a rehire with manual initiation, it is not possible to maintain the same email address because it serves as the candidate's username. Therefore, initiating or rehiring a new user with the same email address of the previously profile, is not feasible.
  2. If initiate with the same email address is needed, a hard purge to the old profile/user is required.

See Also

Keywords

rehire, onboarding, manual onboarding, email address, username, error message, completed status, rehire process, onboarding block, add new hire to onboarding , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem

Product

SAP SuccessFactors Onboarding all versions