Symptom
Error message: "There's already a user with username or email ID X in the system. Enter a different email ID and try again."
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Navigate to "Add new hire to onboarding" in the Admin Center.
- Fill all required fields, including the same email address used in the previous profile.
- Observe the error message: "There's already a user with username or email ID X in the system. Enter a different email ID and try again."
Cause
Since the email address is used as the username, it is not possible to rehire or initiate a new hire with the same email address.
Resolution
- Even though your proposal involves a rehire with manual initiation, it is not possible to maintain the same email address because it serves as the candidate's username. Therefore, initiating or rehiring a new user with the same email address of the previously profile, is not feasible.
- If initiate with the same email address is needed, a hard purge to the old profile/user is required.
See Also
Keywords
rehire, onboarding, manual onboarding, email address, username, error message, completed status, rehire process, onboarding block, add new hire to onboarding , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem
Product
SAP SuccessFactors Onboarding all versions
SAP Knowledge Base Article - Public