Symptom
It is not possible to assign multiple 'Payment Transaction Type Groups'(processing CAMT.053 and CAMT.054) to a single bank account in the 'Manage Bank Accounts' app.
Environment
SAP S/4HANA Cloud Public Edition
Cause
- The transaction type group must be maintained at 'Bank Account' level.
- This is standard system design and cannot be changed via configuration in SAP S/4HANA Cloud Public Edition.
Resolution
- It is not possible to assign multiple Payment Transaction Type Groups to a single Bank Account.
- The system requires a Transaction Type Group to be defined at Bank Account level.
When no Transaction Type Group is assigned:
- Leaving the field empty does not allow the system to dynamically derive the transaction type from the selected format during upload.
- The system cannot determine posting rules.
- An error message 'No transaction type assigned to bank account & &' occurs during bank statement import.
To enable processing of CAMT.054 files, ask bank to:
- Add the prefix <54> to the following XML node inside the CAMT.054 file Ntry > BkTxCd > Domn
- This prefix allows the system to correctly interpret CAMT.054 transactions within the maintained Transaction Type Group.
- Contact your bank and request that:
The prefix <54> is included in the node Ntry > BkTxCd > Domn
The modification is applied to all CAMT.054 files delivered. Once implemented, CAMT.054 bank statements will be processed correctly.
See Also
KBA 0003517704- No transaction type assigned to bank account in Public Cloud
Keywords
payment transaction type group, manage bank accounts app, bank relationship tab, multiple transaction type, CAMT.053, CAMT.054, MT940, transaction type assignment, FAR_BS_FILES002, bank statement processing, electronic bank statement, SAP S/4HANA Cloud Public Edition, finance, treasury management, payments and bank communications , KBA , FI-BL-PT-BA-2CL , bank statement (Public Cloud) , FIN-FSCM-CLM-BAM-2CL , Bank Account Management (Public Cloud) , How To
SAP Knowledge Base Article - Public