SAP Knowledge Base Article - Public

3715950 - Issue updating Picklist fields on the Candidate Profile on Mobile with CX enabled.

Symptom

External Candidates are unable to update Picklist fields on their Candidate Profile, with CX enabled, as the system does not save the value & the system as a result gets stuck in a loop.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1.  On a Mobile Device as an External Candidate, access your Candidate Profile.
  2. Attempt to update any Picklist field value & select OK
  3. The system will not save the value, it stays on the same Picklist selection screen. It's not possible to proceed.

Cause

This is a known issue.

Resolution

The Engineering team has developed a code fix for this issue. The target date for this to be available is on the b2605 release, which is currently scheduled to be deployed on April 13th, 2026 for Preview and on May 15th, 2026 for Production.

Keywords

Candidate Experience, Android, IOS, defect, refresh. , KBA , LOD-SF-RCM-CAN-CX , Candidate eXperience redesigned , Known Error

Product

SAP SuccessFactors Recruiting all versions