SAP Knowledge Base Article - Public

3715988 - Error when using Custom dictionaries

Symptom

Selecting a newly created custom dictionary gets the screen stuck at opening a quote.

Environment

 SAP CPQ

Reproducing the Issue

  1. Open Quote
  2. Go to user settings 
  3. Change Custom dictionary

Cause

Possible cause is an extra line break (an unintended “Enter” at the end of the text)

Resolution

Translation values are used internally by the system in a way where line breaks are not allowed. Even though the extra line is not visible when editing the text, the system still reads it and considers it as invalid input which then causes an error.

How to handle line breaks properly:

  • If a line break is needed, simply remove the extra Enter at the end.
  • If a line break is not needed, it must be explicitly added using '\n' at the end of the text. This way the system knows it is intentional and will not throw an error.

See Also

Dictionaries Creating Custom Dictionary 

Keywords

Quote, Custom, dictionaries, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To

Product

SAP CPQ all versions