Symptom
You have just rehired and employee with new employment and the IPS sync job is trying to sync that user, however you noticed that instead of syncing the new login name, it is syncing the employee with the old login name.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors
- SCIM APIs
Reproducing the Issue
- Rehire any inactive employee
- Once the rehire is completed, wait for the sync job to run
- Notice that the old username was synced instead
Cause
The first thing that needs to be understood is that SCIM API do not use data only from the User entity, it is actually based on the UserAccount.
The second thing that needs to be understood is that regardless of how many employments a user may have, it must only have one user account.
Now, understanding this context there could be 2 caused for this:
- You have enabled the Login with Old Username feature:
If you have enabled this EC feature, this means that whenever an employee is rehired with new employment, on the useraccount the login name (or username in successfactors) will always be the old one, regardless of the value you have chosen during the hire process.
This can be seen in the image below: - Data mismatch in the user account: If you do not have this feature enabled and same yet the wrong username is returning, this means that there might be a data mismatch in the UserAccount where the new employee is using the old login account.
Resolution
- Go to Manage Login Accounts
- Search by the affected user
- Observe if the login name field is the one you expect
- If not, then you can click on 'Change Login Account' and select the username you want to sync with the inactive user
Keywords
KBA , LOD-SF-INT-SCI , SCIM API , LOD-SF-INT-ODATA , OData API Framework , How To
SAP Knowledge Base Article - Public