Symptom
The unit of measure (UoM) defaults to "Hours (H)" instead of "Days" when maintaining the service price for condition type PSP0 in the "Manage Prices - Sales" app.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Run the "Manage Prices - Sales" app.
- Enter the condition type PSP0.
- Select the key combination "Material with release status".
- Enter the sales organization "1715", distribution channel "10", and material "U002".
- Observe that the unit of measure defaults to "Hours (H)" and cannot be changed to "Days".
Cause
The reported behavior is a system limitation. It is not recommended to work with "Days" as a unit of measure as part of the professional service process that includes time and expense billing, this is because plan values in work packages are based on hours.
Resolution
Within the Professional Services scope items (for example, J11, 4E9, J14, etc.), project planning supports only hours as the unit of measurement. Alternative units such as days are not supported in project planning.
As a workaround, planning should be performed using hours. It is recommended to define internally how many hours correspond to one day according to the business requirement. Any necessary unit conversions can then be handled in subsequent processes where required (for example, defining that 8 hours correspond to 1 day).
If this functionality is required as a standard feature, a request can be submitted via the SAP Customer Influence Portal to have the enhancement considered for future releases: 2963059 - How to Submit Feature Requests for SAP S/4HANA Cloud Product
See Also
Keywords
unit of measure, hours, days, manage prices - sales app, condition type PSP0, professional services, SAP S/4HANA Cloud Public Edition, service price, resource mapping, work packages, project planning, scope items, time and expense billing, unit conversion, U002, 1715, distribution channel 10 , KBA , SD-MD-CM-2CL , Conditions and Condition Maintainance (Public Cloud) , Problem
SAP Knowledge Base Article - Public