SAP Knowledge Base Article - Public

3716973 - Daily Knowledge Base Synchronization job is not running/executing

Symptom

"Enable Daily Knowledge Base Synchronization" is activated and scheduled for execution at anytime, but the job does not run.

Environment

SAP CPQ

Reproducing the Issue

  1. Navigate to Setup
  2. Select Providers
  3. Choose SAP Integrations
  4. Access SAP Variant Configuration and Pricing Provider Settings
  5. Open Knowledge Base Synchronization Settings
  6. Enable Daily Knowledge Base Synchronization
  7. Observe that Sync does not execute at scheduled time.

Cause

Possible causes:

  • Wrong domain name in KbSyncDomainMapping table due to faulty migration.

OR

  • Tenant was copied from another environment and with it row in KbSyncDomainMapping was copied as well.

Resolution

Create a Support ticket as internal teams need to check if the issue is cause by an incorrect domain name, and reference this KBA.

See Also

Keywords

Daily, Knowledge Base Synchronization, CPQ, KbSyncDomainMapping table, Recurring Job, Synchronization Settings, Variant Configuration, Pricing Provider Settings , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Bug Filed

Product

SAP CPQ 2026