Symptom
"Enable Daily Knowledge Base Synchronization" is activated and scheduled for execution at anytime, but the job does not run.
Environment
SAP CPQ
Reproducing the Issue
- Navigate to Setup
- Select Providers
- Choose SAP Integrations
- Access SAP Variant Configuration and Pricing Provider Settings
- Open Knowledge Base Synchronization Settings
- Enable Daily Knowledge Base Synchronization
- Observe that Sync does not execute at scheduled time.
Cause
Possible causes:
- Wrong domain name in KbSyncDomainMapping table due to faulty migration.
OR
- Tenant was copied from another environment and with it row in KbSyncDomainMapping was copied as well.
Resolution
Create a Support ticket as internal teams need to check if the issue is cause by an incorrect domain name, and reference this KBA.
See Also
- Refer to: Knowledge Base Synchronization Settings
- Refer to: SAP Note 3295855 - Knowledge Base Manual Synchronization does not work
- Refer to: SAP Note 3393324 - Setting the CPQ CPS synchronization more than once per day
- Refer to: SAP Note 3667216 - Delete statement conflict with reference constraint during knowledge base synchronization
Keywords
Daily, Knowledge Base Synchronization, CPQ, KbSyncDomainMapping table, Recurring Job, Synchronization Settings, Variant Configuration, Pricing Provider Settings , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Bug Filed
Product
SAP CPQ 2026
SAP Knowledge Base Article - Public