Symptom
- The email ID in the locked account associated with the old Worker ID cannot be updated directly due to entry source restrictions via SOAP API.
- The old Worker ID remains active, causing potential synchronization issues.
- The email field is not editable in Manage Workforce.
Environment
SAP S/4HANA Public Cloud Edition
Reproducing the Issue
- Attempt to update the email ID in the locked account associated with the old Worker ID using Manage Workforce.
- Observe that the email field is not editable due to entry source restrictions via SOAP API.
Cause
The email field in the locked account is restricted from editing because the entry source is via SOAP API.
Resolution
- Update the email ID in the locked account associated with the old Worker ID to a dummy email ID (e.g., dummy.com) using SOAP API.
- Terminate or delete the old Worker ID using the ILM process. Refer to the SAP Community blog for scheduling an ILM job: How to schedule an ILM job for deleting employee d... - SAP Community
See Also
Keywords
email update, locked account, worker id deletion, s/4hana cloud, workforce integration, SOAP API restriction, ILM process, dummy email, synchronization issues, manage workforce , KBA , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , Problem
Product
SAP S/4HANA Cloud Public Edition all versions
SAP Knowledge Base Article - Public