SAP Knowledge Base Article - Public

3717567 - The text IDs are not available for Custom Business Partner Grouping in the app Manage Business Partner Master Data

Symptom

When attempting to add text within the BP role Customer (FLCU01) for the Custom Business Partner Grouping when trying to create a new Text field, the F4 help does not display any options.

Environment

SAP S/4HANA Public Cloud Edition

Reproducing the Issue

  1. Open the Manage Business Partner Master Data app.
  2. Create a Customer BP (FLCU01) with the Custom business partner grouping .
  3. Navigate inside the Customer role (FLCU01) to the Text tab.
  4. Try to create a new entry and maintain texts for the customer.
  5. Observe that no text IDs are available for selection in the F4 Help.

Cause

The F4 Help for Custom BP Grouping is not functioning because this grouping is assigned to the Account Group, which does not have any Text IDs associated with it.

Resolution

  1. Navigate to the Show Filters option in the relevant application.
  2. Remove the filter applied to the Account Group field to access the complete dataset of Text IDs.

To check to which Account group this Custom Grouping is mapped follow the below steps,

Follow below steps for maintaining customer account group in Manage Your Solution' app:

  1. Open 'Manage Your Solution' app.
  2. Navigate to 'Configure Your Solution'.
  3. Choose configuration activity '102741 - Define Number Assignment for Direction BP to Customer'.
  4. Display & select the relevant project.
  5. Maintain appropriate grouping to customer account group.

In case while using SAP Central Business Configuration (CBC) :

  1. Log on to the project experience in SAP Central Business Configuration.
  2. Select the relevant project.
  3. Navigate to the configurations activity tab.
  4. Search for the configuration activity '102741 - Define Number Assignment for Direction BP to Customer'.
  5. Select the configuration activity to navigate directly to the SAP S/4HANA Cloud system.
  6. Display & select the relevant project.
  7. Maintain appropriate grouping to customer account group. 

Keywords

business partner group ZSTA, text IDs unavailable, F4 Help issue, SAP S/4HANA Cloud Public Edition, account group ZSTA, manage business partner master data, SSCUI 102741, text maintenance, BP grouping ZPER, BP grouping BP02, text dataset access. , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , Problem

Product

SAP S/4HANA Cloud Public Edition all versions