Symptom
A sales order with multiple (e.g., more than 20) line items is created using the Fiori app, where all items are, e.g., services with item category CTAD (milestone billing plan). Feeling that maintaining the billing plan at item level in the Fiori app is time-consuming, the user saves the sales order first and then accesses the "Change Sales Orders - VA02" WEBGUI application to maintain the billing plan at the header level. However, when attempting to set up the billing plan at header level in the WEBGUI application, the net value field is displayed as zero under the header-level "Billing Plan" tab, although the sales order is complete and has a net value. As a result of the zero billing plan, invoicing is not possible.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Create a sales order in the Fiori app with multiple (e.g., more than 20) line items, all using item category CTAD (milestone billing plan).
- Save the sales order.
- Access the "Change Sales Orders" GUI application.
- Attempt to set up the billing plan at the header level.
- Observe that the net value field is displayed as zero.
Cause
The "Enable Billing Plan" button is not clicked in the Fiori app. As a result, no header billing plan is maintained during the sales order creation.
Resolution
- Click the "Enable Billing Plan" button.
- Click the "Create" button under the "Billing Plan" tab.
- Add the Billing Plan details on the header level.
- Now it will be possible to bring the header billing plan data to the item level.
Keywords
header billing plan, net value zero, milestone billing plan, CTAD item category, sales order, Fiori app, GUI application, SAP S/4HANA Cloud Public Edition, invoicing issue, billing plan value. , KBA , SD-BIL-IV-BP-2CL , Billing Plan (Public Cloud) , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , Problem
SAP Knowledge Base Article - Public