SAP Knowledge Base Article - Public

3718692 - ASK HR: Tickets Are Getting Auto-Closed In C4C

Symptom

 Tickets are getting auto closed by Technical User (_ECSC_BTP)

Environment

SAP Cloud For Customer

SAP Success Factors

Reproducing the Issue

  1. Go to Service Work center
  2. Go to Tickets Work Center View.
  3. Set ticket status to 'Waiting for Employee' or 'On-Hold'
  4.  Observe that tickets are auto-closed despite the status.
  5. Go to the Changes Facet of the closed ticket 
  6. Status changed by Technical User (_ECSC_BTP)

Cause

The C4C destination is configured to use X.509 certificate authentication. The system actually closes the ticket using the X509 certificate technical user’s credentials. Therefore no matter who closed the ticket on AskHR interface it will show as technical user in the C4C side as its using the certificate based authentication method with the technical user.

Resolution

The ticket closed on ASK HR side will lead closure of ticket in C4C. On C4C side you can see its closed by technical users(Technical User (_ECSC_BTP)) quickly after the AskHR ticket closed and most of the times these tickets are without processors. That's the only explanation of this behavior, AskHR / C4C is not closing tickets automatically. This is the Expected System Behavior

Keywords

ASK HR, C4C, tickets , auto close, status, Technical User (_ECSC_BTP), success factor, X.509 certificate authentication,  , KBA , LOD-CRM-SRP , Service Request Processing , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , Problem

Product

SAP Cloud for Customer core applications all versions ; SAP SuccessFactors HCM Core 2505