Symptom
- Error message: "Navigation to this application is not supported" encountered while navigating to the project planning.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Access the enterprise projects app.
- Select the project and navigate to the related apps section.
- Click on the project planning app.
- Observe the error message: "Navigation to this application is not supported".
Cause
- The error message "Navigation to this application is not supported" is related to missing authorization for the user.
Resolution
Verify whether the affected user has the required business catalogs assigned.
You can check the required Business Catalog in Fiori App Library.
Check tab 'Implementation Information', and check Business Catalogs part.
You can also verify the user's existing Business Catalogs with app IAM Information System.
For App Project Planning, kindly assign the following business catalogs below to the user:
- SAP_PPM_BC_PROJ_MGMT_PC: Enterprise Projects - Project Management
- SAP_PSM_BC_MON_BDGTSP_PC: Budget Specialist - Budget Monitoring
- SAP_PS_BC_PROJ_CONTRL_MC: Enterprise Projects - Project Financial Controlling
- SAP_PS_BC_PROJ_DEMAND_MC: Enterprise Projects - Project Demand
Keywords
navigation error, project planning app, enterprise projects app, related apps, authorization missing, business catalogs, SAP_PPM_BC_PROJ_MGMT_PC, SAP_PSM_BC_MON_BDGTSP_PC, SAP_PS_BC_PROJ_CONTRL_MC, SAP_PS_BC_PROJ_DEMAND_MC, Navigation to this application is not supported , KBA , PPM-SCL-STR , Project Structure (Public Cloud) , Problem
SAP Knowledge Base Article - Public