Symptom
After rejecting a Sales Order, the field "Confirmed Quantity remains with the same value before the Sales Order was updated with the rejection reason.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Access the "Create Sales Orders - VA01" app.
- Select the document type "OR".
- Create a sales document.
- After inserting the material, go to the item level and check the "Schedule Lines" tab.
- The "Confirmed Quantity" field has the same value as the number of materials inserted.
- Go back to the header level, go to the "Reason for rejection" tab
- Select a reason and save the document
- Go back to the item level, see that the confirmed quantity value remains unchanged.
Cause
When the reason for rejection is set, the requirement is deleted and therefore the field "confirmed quantity" and the value inside it both become irrelevant. Due to this, the stock will not be allocated for the rejected order, only the confirmed quantity is still displayed in sales order.
The field "Confirmed quantity" in the CDS View I_SalesDocumentScheduleLine will also not be updated, the system will remain showing the same value in the "Customer Data Browser" app.
Resolution
Instead of the field "Confirmed quantity" being updated, the system updates the material reservation, this can be observed in the "Monitor Product Availability" or in the "Display Product Availability" app.
Keywords
confirmed, quantity, unchanged, reason, rejection, sales, order, document, va01, create, change, schedule, lines, tab, updated, atp, reserved, material, requirement, production, product, display, availability , KBA , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , CA-ATP-2CL , Available to Promise (ATP) (Public Cloud) , SD-BF-AC-2CL , Availability Check (Public Cloud) , Problem
SAP Knowledge Base Article - Public