SAP Knowledge Base Article - Public

3719352 - The Customer Project Invoice Request Did Not Change the Status to "To Be Invoiced" After Cancelling the Associated Invoice

Symptom

The Customer Project Invoice Request is in the status "Processed" and "Cancelled" in the item level but the expected status is "To Be Invoiced".

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Customer Invoicing work center.
  2. Select the Invoice Requests view.
  3. Select All Invoice Request.
  4. Search for the invoice request XYZ.(XYZ stands for the invoice request ID)
  5. The status of the Customer Project Invoice request XYA is "Processed", the status in the item level is showing as "Cancelled". 

Cause

Customer Project Invoice Request XYZ has the status "Processed" and not “To Be Invoiced” because the Project Invoice Request XYZ is cancelled.

You can check this as follows:

  1. Navigate to the Customer Invoicing work center.
  2. Select the Project Invoicing view and the Project Invoice Requests sub view.
  3. Select Project Invoice Request XYZ.

You can see that the Project Invoice Request XYZ has the status “Cancelled”.

Resolution

This is the expected system behavior.

Once the Project Invoice Request is cancelled, the item in the Customer Project Invoice Request will also be cancelled and the status of the Customer Project Invoice Request changes to "Processed" and in the status in the Details section for the item is "Cancelled". 

If the project invoice request has not been invoiced yet, all time and expense items that were assigned to the project invoice request will be made available for invoicing again immediately.

In case the project invoice request has already been invoiced, the time and expense items that were assigned to the project invoice request will not be made available for invoicing again until the customer invoice is canceled as well.

See Also

KBA 2925079 - Not Possible to Release Customer Invoice Due to Error: Conflict detected in item XXX of Project Invoice Request ID / Service Confirmation ID ABC; release not possible

KBA 2472185- The Following Error Occurs for a Customer Project Invoice Request "Item XX: Conflict in item XX; cancellation requested but invoice already exists"

Keywords

invoice request, processed status, to be invoiced, project invoice request, cancellation, conflict in item, invoice already exists, customer invoice processing, SAP Business ByDesign, invoice request ID , KBA , AP-CI , Customer Invoice Processing , Problem

Product

SAP Business ByDesign all versions