SAP Knowledge Base Article - Public

3720013 - Service Agent Role not Visible for Replicated Employees

Symptom

Employee data was replicated from SAP SuccessFactors, but the service agent role was not automatically created for some employees.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Business Partner Data work center.
  2. Select the Service Agents view.
  3. Search for the employee IDs XYZ.
    Observe that the employees XYZ are not visible in the results.

Cause

The replication of service agent roles is dependent on the assignment of intercompany projects to employees. If an employee is assigned to a project belonging to a different company, the system automatically creates the service agent role.

Resolution

To verify whether the employee is assigned to an intercompany project.

  1. Navigate to the Employee Data work center.
  2. Select the Employees view.
  3. Search for the relevant employee ID.
  4. Open the employee record and check the project assignment details.

If the employee is not assigned to an intercompany project, assign the relevant project. Once the project is assigned, the system will automatically create the service agent role for the employee.

To confirm the role creation:

  1. Navigate to the Business Partner Data work center.
  2. Select the Service Agents view.
  3. Search for the employee ID XYZ.

See Also

 KBA 1886522 - Some of the Employees are also Having a Role Service Agent

Keywords

service agent, employee replication, intercompany project, role assignment, SAP SuccessFactors, employee data, replication issue. , KBA , AP-HMD-RPL , HCM-Master Data Replication , Problem

Product

SAP Business ByDesign all versions