Symptom
- The visibility of the attachment type field on the product UI is not functioning as expected.
- When attempting to add an attachment, only fields for document upload and title description are visible, while the type field remains unavailable despite being marked as visible in adaptation settings.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to the product administration work center in SAP Sales Cloud.
- Open any product.
- Attempt to add an attachment to the product UI form the attachments section.
- Observe that only fields for document upload and title description are visible, while the attachment type field is missing.
Cause
The "Attachment Type" field has certain pre-requisites for it to be visible, and it can only be visible on certain objects, and "Products" is not part of the available objects.
Resolution
Attachment types have to be defined in business configuration for specific objects:
- Navigate to Business Configuration.
- Open the activity list and search for "Customer-defined document types for attachment."
- Define the attachment types here for specific objects.
- Note that there are only a limited number of objects available for usage. Products are not part of this list, hence "Attachment Type" cannot be made available for the products screen. This is currently a system limitation.
- Refer to the influence page for requesting changes to this behavior:
https://influence.sap.com/sap/ino/#/campaign/1868
See Also
KBA KB0854245 - Attachment Document Type for type "Web Link" will always be disabled (https://me.sap.com/notes/0003002044)
Keywords
attachment type, document type, visibility issue, sap sales cloud, product administration, sdk rules, web link, local file, adaptation settings, master data, field limitation, system limitation, customer-defined document types, business configuration , KBA , LOD-LE-PRD , Product + Product Category , Product Enhancement
SAP Knowledge Base Article - Public