SAP Knowledge Base Article - Public

3720153 - Alerts not Correctly Updated in Customer Hub

Symptom

Alerts in the Customer Hub in your test environment are not correctly updated even though the rules are being met.

Environment

  •  SAP Sales/Service Cloud version 2

Reproducing the Issue

  1. Log in to the test environment and navigate to the Agent desktop.
  2. Search for an Individual Customer that meets the rules for an alert created in your system in the Agent desktop.
  3. Click on the accept button.
  4. Observe that the alert is not displayed.

Cause

Alerts were not triggering due to an issue with alert configuration.

Resolution

When either creating or editing an alert type, please ensure that you chosen a saved filter of the respective entity in the Test Evaluation Criteria field so that the alert applies to a limited set of records. This filtering prevents the system from unnecessarily updating alerts for all records (without actual events occurring).

For a test tenant, the selected Test Evaluation Criteria must contain fewer than 100 records. For a production tenant, there are no restrictions, however, any modifications made to the alert rule will reflect after the weekend run.

If this is a test tenant it is possible that since the filter criteria has not been set or that the limit of 100 has been passed that the alerts have stopped working.

See Also

Refer to: SAP Help Documentation.

Keywords

alerts, individual customer, customer hub, missing email, missing phone number, update issue, SAP Sales Cloud, SAP Service Cloud, test evaluation criteria, alert configuration, records limit , KBA , CEC-CRM-ML , Machine Learning for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0