SAP Knowledge Base Article - Public

3720878 - Inconsistencies on the Global Search behavior for Employees with correct Permissions.

Symptom

The system is correctly configured to enable the global search and the users have the related permissions, but the search index is presenting inconsistencies / different behaviors for employees with same permission. 

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

The behavior is present ONLY on the Global Search. 

For example:

  • Employee A has permission to the Job Title and Location.
  • When they access Employee's B profile, they can see this data.
  • However, when they search for Employee B, this information is not showing below the Employee's name. 

Cause

This issue may be caused by a stale index on the search database.

Resolution

If the behavior happens only on the SuccessFactors Global Search, a Search Index needs to be done by the SuccessFactors Platform Team. In order to do that, the customer needs to create a ticket under the LOD-SF-PLT-SRH component, providing the Company ID and the steps to replicate the issue. 

If the issue is present in other scenarios (such as Employee's profile, Manage Data, or any other place), please create a ticket under the Specific Module.

SAP Technical Support Team: For more information, check the Internal Memo.

See Also

Global Header People Search

Configuring People Search

Keywords

Global Search, People Profile, Job Tile, Employee Search, success factors, refresh, reindex, action search, missing, re-index, search index, re index, reindexing, indexing , KBA , LOD-SF-PLT-SRH , Search , LOD-SF-EP-HED , People Profile Header Ribbon , LOD-SF-EP-DIR , Employee Directory Search , LOD-SF-EP-FPP , People Profile - Full Profile , Problem

Product

SAP SuccessFactors HCM Core 2505