Symptom
When adding a new product hierarchy sub-node, the following error message is received: "Please correct your inputs. Value & already exists in this hierarchy. Specify a different value."
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open Manage Product Hierarchies app.
- Open a Product Hierarchy.
- Navigate to a node.
- Click on "Add".
- Search and select a value that already exists in the product hierarchy.
- Click "Save".
- Error message "Please correct your inputs. Value & already exists in this hierarchy. Specify a different value." appears.
Cause
This is the standard system behavior.
In the product hierarchy, a node can only be assigned (or be part) once within a single hierarchy structure.
The system does not support maintaining multiple occurrences of the same node or subnode within the same product hierarchy.
As a result, duplicate entries of identical nodes/subnodes in one hierarchy are not allowed
Resolution
As a workaround, it may be useful to maintain the same node in multiple product hierarchies.
Creation of a new product hierarchy can be done through following steps:
- Open Manage Product Hierarchies app.
- On the Hierarchy List, click on "Create" (top right).
- Fill mandatory fields.
- Open the newly created Product Hierarchy.
- Maintain the desired new hierarchy with the same value as other product hierarchies.
- Save and activate such hierarchy.
See Also
- Manage Product Hierarchies - Fiori Apps Library
- Manage Product Hierarchies - SAP Help Portal
- KBA 2862172 - Unable to add subnodes/products to a Product Hierarchy in the App 'Manage Product Hierarchies'
Keywords
product hierarchy, manage product hierarchies app, value already exists, error message, sub-node, hierarchy creation, duplicate value, standard system behavior, workaround, hierarchy node, SAP S/4HANA Cloud , KBA , LO-MD-FIO-MM , Fiori UI for Product Master , LO-MD-FIO-MM-2CL , Fiori UI for Product Master for Public Cloud , Problem
SAP Knowledge Base Article - Public