Symptom
- Workflow triggers email containing expired Survey link, even after creating a new Survey version and retriggering a new email.
- Error message displayed when clicking on the Survey link: "Survey has expired."
Environment
SAP Cloud for Customer
Reproducing the Issue
- Create a Satisfaction Survey with a certain validity period.
- Associate the Survey with a Workflow rule and trigger the Workflow.
- Receive an email containing the survey link.
- Open the survey link after the validity period has expired:
- The link displays a "Survey expired" message.
- Create a new version of the Survey within a new valid period.
- Retrigger the Workflow.
- Receive a new email containing the survey link.
- Open the Survey link
- The "Survey expired" message persists despite the new survey version being created.
Cause
- For the same business object and the same recipient, a new URL cannot be generated once the previous URL has been created.
- The backend logic does not generate a new URL if the valuation collection (Survey UUID, BTD Reference UUID, Recipient UUID) has already been collected once.
Resolution
In order to generate a link with the new Survey version, a new business object or new recipient must be used for the backend to generate the updated URL.
Keywords
survey expiration, workflow email, expired survey link, survey version, survey validity, survey URL, opportunity status, satisfaction survey, backend logic, valuation collection , KBA , LOD-LE-SUR , Survey , LOD-CRM-WKF , Workflow , Problem
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public