Symptom
- Field "Reference 1 ID by Business Partner" is not available in the settings of "Display Line Items in General Ledger".
- Only fields "Reference 1" or "Reference 2" are available in Display Line Items in General Ledger.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the "Display Line Items in General Ledger" app.
- Navigate to the settings to view available fields.
- Observe that "Reference 1 ID by Business Partner" is not listed among the available fields.
Cause
- The "Display Line Items in General Ledger" app utilizes the G/L view of documents, relying on CDS view C_JOURNALENTRYITEMBROWSER, which is based on table ACDOCA.
- Reference fields stored in table BKPF (entry view) are not included in this view by default.
- The "Manage Journal Entries" app operates on the Entry View of documents (CDS view I_JournalEntry), which includes header-level data such as Reference 1 and Reference 2 and line-item data such as Reference 1 ID by Business Partner.
- The "Display Line Items in General Ledger" app focuses on ledger-specific line-item reporting and excludes these header-level fields.
Resolution
- Use the "Display Line Item Entry" app (App ID F2218), which is based on the entry view of documents (BKPF and BSEG) and includes CDS view I_JournalEntry, where "Reference 1 ID by Business Partner" is available.
- If access to the "Reference 1 ID by Business Partner" field is required within the "Display Line Items in General Ledger" app, create a custom field to include the required data.
- Refer to the following SAP Knowledge Base Articles for further guidance:
- SAP Help Portal: Add Extension Fields for the Display Line Items in General Ledger App
See Also
Keywords
reference 1 id by business partner, display line items in general ledger, missing field, header-level data, line-item data, CDS view, BKPF, ACDOCA, I_JournalEntry, F2218, custom field, SAP S/4HANA Cloud , KBA , FI-FIO-GL-IS-2CL , Reporting Apps (Public Cloud) , Problem
Product
SAP S/4HANA Cloud Public Edition all versions
SAP Knowledge Base Article - Public