Symptom
In the Cloud Connector ljs_trace.log :
Caused by: com.sap.scc.servlets.CriticalSccException: Preparation of tunnel certificate for 6c175d6a-bf38-4e25-9db1-0b5b5972b71b@cf.sa30.hana.ondemand.com account failed due to unknown exception.
at com.sap.scc.ui.SubaccountControl.applyConfig(SubaccountControl.java:225)
at com.sap.scc.ui.SubaccountControl.createSubaccount(SubaccountControl.java:115)
... 50 common frames omitted
Caused by: com.sap.scc.servlets.SccHandshakeException: SCC handshake failed: 401 — Unauthorized
And 400 errors:
com.sap.core.connectivity.tunnel.core.handshake.TunnelHandshakeException: Invalid status of handshake response: 400 Bad Request at com.sap.core.connectivity.tunnel.client.handshake.ClientProtocolHandshaker.finishHandshake(ClientProtocolHandshaker.java:178
Environment
- SAP Cloud Connector 2.10.2 or higher
- SAP BTP Cloud Foundry environment
- SAP Analytics Cloud
Reproducing the Issue
- Log on to your instance of SAP Cloud Connector.
- On the Connector page, choose Add Subaccount
- Enter the region, Subaccount, Location ID, and Login email and password
- Save your changes.
Notice : Error 'An authorization problem occurred when downloading the configuration. Check the spelling of the subaccount name, user, and password. See 'Log And Trace Files' and in particular ljs_trace.log for details'.
Cause
The email ID used is linked to multiple user IDs in the SAP BTP environment. The SAP BTP/SCC connectivity layer is designed to support only a one-to-one mapping between email addresses and user identifiers, and therefore rejects the handshake attempt during subaccount configuration
Resolution
Create a new SAP BTP user with a unique email address and dedicated user ID.
See Also
- Refer to: KBA 2571763 - Authorization problem in SAP Cloud Connector when adding Cloud Foundry subaccount.
- Refer to: KBA 3068483 - Error when trying to renew SAC subaccount certificate in Cloud Connector.
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
Keywords
sap cloud connector, cloud foundry subaccount, sap analytics cloud, authorization issue, handshake error, 401 unauthorized, 400 bad request, tunnel handshake exception, subaccount configuration, email mapping issue, sap btp user, unique email address, user identifier, connectivity layer, sap btp environment, sap analytics cloud subaccount , KBA , LOD-ANA-AQU , Import Data Connections (Acquiring Data) , Problem
SAP Knowledge Base Article - Public