SAP Knowledge Base Article - Public

3721643 - When applying to a job using Android phone, picklist dropdown values are not displaying - Recruiting Management

Symptom

Using Android phone to access Career Site and apply to a job posting, the picklist dropdown values do not display when editing existing entry.

It also happens on iPhone when using Google browser, but it works fine in Safari.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Use an Android phone and access the Career Site
  2. Apply to a job posting
  3. Start filling out picklist fields
  4. Go back to picklist fields and attempt to correct or change the inputs
  5. Observe that dropdown values do not display or it appear briefly but quickly disappear

Cause

On mobile devices, the appearance of the software keyboard triggers a window resize event. This event listener incorrectly executes a "hide" function on active popups, causing the dropdown to flicker briefly before being dismissed.

Resolution

Engineering Team is already working on the fix in which deployment is scheduled on:

  • Preview: March 10, 2026
  • Production: March 12, 2026

See Also

3672988 - iOS Mobile issue with Reimagined Candidate Experience - Recruiting Management

Keywords

dropdown values, job application, android devices, mobile interface, mobile apply, picklist dropdown issue, PTCH-49236, RCM-155920, KI2H2025   , KBA , LOD-SF-RCM-MOB , Mobile Interface, Mobile Apply , Known Error

Product

SAP SuccessFactors Recruiting all versions