SAP Knowledge Base Article - Public

3721695 - No data returned when previewing a sales plan from the CDS view I_SlsPerformancePlanActualCube in the "Manage Customer Data Browser" app - SAP S/4HANA Cloud Public Edition

Symptom

A sales plan with lower-case name characters cannot be previewed from the CDS view I_SlsPerformancePlanActualCube in the "Manage Customer Data Browser" app.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Create a sales plan with lower-case name characters using the "Manage Sales Plans" app.
  2. Navigate to the "Manage Customer Data Browser" app and query the CDS view I_SlsPerformancePlanActualCube.
  3. Click "Parameter" and enter the corresponding fields including the sales plan name.
  4. Observe that no records are returned for the Sales Plan.

Cause

The "Manage Customer Data Browser" app converts the sales plan name to upper-case when querying.

Resolution

The data can be viewed through either of the following options:

  1. Create the sales plan name and version in upper-case.
  2. Create a custom cube using the "Custom CDS View" app, then create a custom query based on the newly created cube (Business Role SAP_BR_ANALYTICS_SPECIALIST is required).
  3. Display query content in the "View Browser" app by searching for the created analytical query or C_SlsPerfPlanActualQuery.

Keywords

sales plan, CDS view, I_SlsPerformancePlanActualCube, Manage Sales Plans, SAP S/4HANA Cloud Public Edition, visibility issue, Sales Plan configuration, C_SlsPerfPlanActualQuery, Manage Customer Data Browser, Sales Plan name, lower-case, upper-case, lowercase, uppercase , KBA , SD-ANA-SP-2CL , Sales Planning (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions