SAP Knowledge Base Article - Public

3721734 - Lead owner changes not reflected in account owner after conversion

Symptom

  • When the owner field in a lead is changed twice and the lead is converted to an account and contact, the owner in the account reverts to the original owner instead of reflecting the latest changes.
  • The issue occurs consistently, and the account changes tab does not show the updated owner details.

Environment

  • SAP Cloud for Customer
  • SAP Cloud Applications Studio

Reproducing the Issue

  1. Login on UI.
  2. Change the owner field in the lead.
  3. Convert the lead to an account and contact.
  4. Save and open the account converted from the lead.
  5. Observe that the owner field in the account reverts to the original owner instead of reflecting the latest changes made in the lead.

Cause

The custom code cause the issue.

Currently, the custom logic for copying the Lead Owner to the Account is implemented in Action Event of BusinessPartner BO .

Resolution

Instead of placing the logic in this action, it is recommended to move this logic to the AfterModify or BeforeSave event of the Account BO.

Keywords

lead owner, account owner, conversion issue, PDI,Custom code,Action,AfterModify,BeforeSave, , KBA , AP-RC-BDS-SCR , ByDesign Studio Scripting (ABSL) , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud Applications Studio all versions ; SAP Cloud for Customer core applications all versions