SAP Knowledge Base Article - Public

3721769 - Incorrect service contract date calculation in a service contract item in a solution order - SAP S/4HANA Cloud Public Edition

Symptom

When using a custom date profile for the contract date calculation, it does not take the current start date to calculate the end date of the service contract item in solution order item. It always uses the previous start date.

Environment

SAP S/4HANA Cloud Public Edition

Cause

One of the possible cause is that the Calculation Pos. of the date type is not set properly in the date profile.

Resolution

  • Navigate to the configuration activity "Assign Date Profile to Item Categories in Service" (ID: 104328) and check the date profile assigned to the corresponding item category.
  • Check the "Calculation Pos." settings of the Date Type "Contract End Date" (CONTEND) of the date profile through the configuration activity "Define Date Profile for Service Transactions" (ID: 104301). 
  • The "Calculation Pos." needs to be set as "2" for the Date Type "Contract End Date" (CONTEND) according to the configuration help.

Keywords

service contract, solution order, end date calculation, default time settings, manual entry, configuration, SAP S/4HANA Cloud, 104301, Define Date Profile for Service Transactions, CONTEND, date type, date profile, Contract End Date, Calculation Pos. , KBA , CRM-S4-SOL-SLO , S4CRM: Solution Order , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions