Symptom
Assignment rule is not selecting layout for users of a specific role
Environment
Source: portal
Type: Productive System
System ID/Name: CLOUD / my1001619.us1.crm.cloud.sap
Product version: SAP Sales Cloud and SAP Service Cloud Version 2 1.0
System managed by: SAP Cloud Tenant
Install base item: my1001619.us1.crm.cloud.sap
Sold product: CUSTOMER ONDEMAND
Type: Productive System
System ID/Name: CLOUD / my1001619.us1.crm.cloud.sap
Product version: SAP Sales Cloud and SAP Service Cloud Version 2 1.0
System managed by: SAP Cloud Tenant
Install base item: my1001619.us1.crm.cloud.sap
Sold product: CUSTOMER ONDEMAND
Reproducing the Issue
- Log into tenant
- Open adaptation mode
- See Layout is 'Main Layout' - this should be custom layout
Cause
The assignment rule is configured with "Match All," which evaluates to true only when all role entries satisfy the defined condition. This configuration caused the issue.
Resolution
Instead of "Match All," each condition in the assignment rule should be configured use "Match Any"
Keywords
KBA , CEC-CRM-CZM , Customization for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0
SAP Knowledge Base Article - Public