SAP Knowledge Base Article - Public

3722141 - ADLS connection fails with "forbidden" error in SAP Datasphere

Symptom

ADLS connection validation is failing with the error message: "Possible causes of error: Detailed error message (forbidden)"

Environment

SAP Datasphere

Reproducing the Issue

  1. Go to "Connections"
  2. Validate the Microsoft Azure Data Lake Storage Gen2 connection
  3. Connection validation fails with: "Data Flows: Cause: Possible causes of error: Detailed error message (forbidden)
    Replication Flows: Cause: Possible causes of error: Detailed error message (forbidden)"

Cause

The issue is caused by missing network configuration adjustments, specifically the allowance of the SAP Datasphere VNET Subnet in the firewall rules of the Azure storage account.

Resolution

Refer to the prerequisites outlined in the Microsoft Azure Data Lake Store Gen2 Connections: update the Azure Storage allow list, adding the VNet/Subnet of the SAP Datasphere cluster.

Keywords

KBA , DS-DI-CON , Connections , Problem

Product

SAP Datasphere all versions