Symptom
- Pricing category for a business role reflects as "Advanced" despite deactivating all Advanced IAM apps within it.
- Uncertainty regarding whether pricing is determined based on the assigned Business Catalog or active IAM apps within the role.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Assign a standard Business Catalog (Advanced) to a business role.
- Deactivate all Advanced IAM apps within it.
- Retain only Service and Core IAM apps active in the business role.
- Observe that the pricing category for the business role still reflects as "Advanced".
Cause
The pricing is currently determined based on the assigned Business Catalog, regardless of the activation status of individual IAM apps within the business role.
Resolution
- Understand that pricing is currently derived from the assigned Business Catalog, and deactivating IAM apps within the business role does not affect the pricing category.
- Note that SAP is working on a future change where pricing will be calculated based on active IAM apps within the business role.
Keywords
pricing determination, business catalog, advanced apps, sap s/4hana cloud, authorization content, pricing category, custom business role, read-only catalog, license allocation, subscription costs, active apps, IAM app. , KBA , CA-GTF-IAM , S/4HANA Cloud: Authorization Content , Problem
Product
SAP S/4HANA Cloud Public Edition all versions
SAP Knowledge Base Article - Public