SAP Knowledge Base Article - Public

3723193 - Missing or Deleted Job Profile Templates

Symptom

Some or all job profile templates are missing in Manage Job Profile Templates.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors Job Description Manager
  • SAP SuccessFactors Job Profile Builder
  • SAP SuccessFactors Recruiting

Reproducing the Issue

  1. Log into SuccessFactors
  2. In the global search, type Manage Job Profile Templates
  3. Some or all job profile templates are missing

Cause

  • Job profile templates were created in a different language
  • subModule field is populated
  • subModule field was modified
  • Job profile template data was overwritten via import
  • JPB is enabled, but the JDM to JPB migration has not been processed
  • Job profile template data was deleted or purged

Resolution

I. Job profile templates were created in a different language

If job profile templates exist in only one language, other languages will not show data in Manage Job Profile Templates. Use the language dropdown under the Create Template button to switch to the language where the templates were created:

II. subModule field is populated

If the subModule field for a job profile template contains data, it is expected behavior that the template will not appear under Manage Job Profile Templates. Check whether the field contains data using one of the following methods:

III. subModule field was modified

The subModule field must remain blank for the job profile template to display in Manage Job Profile Templates. Changing this field for an existing job profile template breaks data mappings and removes the template from view. You can verify if the subModule was changed and revert the data by using an option below:

IV. Job profile template data was overwritten via import

The externalCode (GUID) field was populated in the import file. This causes the system to overwrite existing job profile templates instead of creating new ones. You can verify if this is the cause and revert the changes by using an option below:

V. JPB is enabled, but the JDM to JPB migration has not been processed

Some customers have the Job Profile Builder appearance but the system framework is still Job Description Manager. Data becomes fragmented between frameworks causing various discrepancies. This situation applies when the following criteria is met:

  • You can locate Manage Job Profile Builder in global search or Admin Center, and
  • You do not see a job named JDM Old to New Sync in Scheduled Job Manager, or you have a check tool error for Job Profile Builder migration successful. (JPBEnabledAndMigrationCheck) 

A Certified Partner engagement is required to complete the migration and resolve discrepancies. If you do not have a Certified Partner, you can look for one using 2149831 - SAP Professional Services / SAP Certified Partner / SAP Account Management Team [SuccessFactors Cloud].

VI. Job profile template data was deleted or purged

This scenario only applies if you have ruled out all scenarios above, or if a user confirmed they configured/performed any of the below actions:

  • Manually deleted the job profile template in Manage Job Profile Templates
  • Imported job profile templates using Manage Job Profile Content Import/Export with the Delete operator
  • Purged job profile templates using Purge Non-Sensitive MDF Business Data for the Job Template object
  • Imported job profile templates with Full Purge selected in Import and Export Data  

Important Notes for this Scenario:

  • If job profile templates were deleted or purged, the data is permanently lost from your system.
  • Engineering cannot restore job profile data once it has been deleted.
  • We do not keep a backup of deletions and cannot process a partial system restore. 

You can recreate the job profile templates using one of the below options:

  • Option 1: Compare your current data against the most recent pre-import backup file. If the deleted job profile template is within the backup file, you can create the job profile template again using one of the following options:
  • Option 2: Check if you had a recent system refresh. Reference the job profile template data in the refreshed system to update your current system.
  • Option 3: As a last resort, you can request a full restore of your system using KBA 2218169 - Data Backup Procedures and Restore Process - SuccessFactors Cloud to retrieve the data you need.

Preventative Measures

To avoid similar data issues moving forward, you can take the following precautions:

See Also

Keywords

KBA , LOD-SF-TIH-JPB , Job Profile Builder , LOD-SF-TIH-JDM , Job Description Manager , LOD-SF-RCM-JOB-JPB , Job Profile Builder and Competencies , Problem

Product

SAP SuccessFactors HCM Core all versions ; SAP SuccessFactors Recruiting all versions