Symptom
Error message encountered: "<ESM_Tenant>.crm.cloud.sap refused to connect."
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Central
- SAP SuccessFactors Employee Central Enterprise Service Management
Reproducing the Issue
- Click on ESM - Get HR Support icon
- Observe the connection error
Cause
Configuration issue during the implementation on ESM side.
Resolution
- Access ESM through direct link.
- Navigate to Users and Control > Settings > Cross-Site Request Forgery (CSRF) Settings > Select "None".
- Add your SF API URL domain, for example "*.sapsf.eu" in the Settings > Content Security Policy > frame-ancestors and ensure it is enabled.
Note: The domain required in frame-ancestors may be different than above example, it depends on the DataCenter.
See Also
- KBA 2215682 - SuccessFactors API URLs and external IPs
- Implementing SAP SuccessFactors Enterprise Service Management | SAP Help Portal
Keywords
SAP SuccessFactors, ESM configuration, CSRF settings, content security policy, refused to connect, frame-ancestors , KBA , LOD-SF-INT-ESM , Enterprise Service Management , Problem
Product
SAP SuccessFactors Employee Central all versions
SAP Knowledge Base Article - Public