SAP Knowledge Base Article - Public

3723829 - When triggering action Place Order in CPQ, it creates several Sales Order.

Symptom

When triggering Place Order in CPQ, it can be seen several timeout error messages in the Event Log (processing time is taking more than 100s), but after some time it is logged several sales order creations. 

Environment

SAP SALES CLOUD CPQ Integrated with SAP S/4HANA

Reproducing the Issue

  • Create a Quote in CPQ
  • Trigger Place Order Action
  • Check on Event Log several attempts to send message to S4
  • After some time, check Event Log several Successful messages being logged for same Quote ID.

Cause

  • Possible cause is use of a custom iFlow, which is triggered with CPQ subscription to event
  • The iFlow processing takes lot of time and because of that CPQ receives timeout error (Processing time is taking more than 100s)
  • On every event, CPQ notification service can retry sending events up to 7 times, and notification is successfully sent only when receiver (CPI) responds with OK response (200 status code)
  • If iFlow processing takes longer than timeout limit, notification is not considered as successful and CPQ tries to send it again.

Resolution

  • Use standard IFlow, as it is already configured to avoid this issue
    • In CPQ standard iFlow, CPQ uses SAP EventMesh which responds quickly to CPQ, and then iFlow listens to the Event Mesh queue and starts processing if new message arrives
  • Customize iFlow to send a response to CPQ as quickly as possible, similar scenario of standard iFlow, and then the rest of processing of the IFlow would not trigger the Retry Mechanism.

Keywords

iflow, timeout, s/4hana, integration, sales order, multiple sales order creation, place order, event mesh, cpi, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ 2024