Symptom
When adding a filter for exclusion in the app 'Sales Volume - Flexible Analysis', the results seem incorrect and not affected by the filter.
Environment
SAP S/4HANA Cloud Public Edition
Cause
For the app 'Sales Volume - Flexible Analysis', Billing Document Items are the data source. Therefore, if the results were not altered by the filter exclusion, this means that no document had this attribute.
E.g.: by choosing the field 'Material Group' as a filter and adding a value to be excluded from the results, if the results haven't changed, this means that there were no billing document items that were using the chosen material group.
Resolution
When setting filters, make sure the selected fields and values are consistent. It's important to:
- Expect a change only in the suitable timeframe.
- E.g.: if the report is separated by month, but only the two last months have billing document items using the selected material group (or other field selected to filter), then only these two last months will be affected by the filtering out.
- Ensure the values used as filters are consistent: they exist and are defined in the system.
- E.g.: if the field material group is selected for filtering out, make sure the material group entered as value is defined in the system through the configuration activity 'Define Material Groups' (102665).
Note: to check the results are if the filter out is working properly, it's possible to filter by the same values, get the results, and then subtract them from the report with no filter, then this should be the result of the filter out by the same value.
See Also
Keywords
sales volume, sales analytics, flexible analysis, filter, filter out, filter exclusion, exclude, remove, report, incorrect, listing, material group, product group, billing document item, sales report , KBA , SD-ANA-2CL , Analytics (Public Cloud) , Problem
SAP Knowledge Base Article - Public