Symptom
The Credit limit card under Customer Insight in Account shows NaN %
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Navigation Menu
- Go to Customers
- Go to Accounts
- Open an Account
- Go to Customer Insights facet
- Under Key Metrics section, credit limit card shows NaN%
Cause
The credit segment data maintained in S/4 HANA does not match the data maintained in the iFlow "Request Credit Account Data from SAP Business Suite" in CPI
Resolution
- Verify the mapping in CPI and ensure that the correct credit segment data as per S/4 HANA is maintained.
- Kindly note that the current standard system behavior does not support more than one credit segment data.
Keywords
customer insights, credit limit check, sap sales cloud, sap s/4hana, cpi mapping, credit segment, buus, pvus, discrepancy, data issue, embedded insights, s4 integration, api, abap logic , KBA , CEC-CRM-INS , Embedded Insights for SAP Sales/Service Cloud , LOD-CRM-SBS-360 , Customer 360 Profile , LOD-CRM-ACC , Account , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public