SAP Knowledge Base Article - Public

3725424 - Editing Time Account Payout date for inactive employee

Symptom

When trying to edit a Payout Request from an inactive employee, the system displays the error message: "The payout date you entered was after the termination date. The system adjusted the date accordingly.".

Environment

  • SAP SuccessFactors Employee Central
  • SAP SuccessFactors HCM Suite 

Reproducing the Issue

  1. Go to Administer Time for the inactive user profile;
  2. Go to Account Payouts section;
  3. Try to edit a Payout Request;
  4. Error message: "The payout date you entered was after the termination date. The system adjusted the date accordingly.".

Cause

Expected system behavior.

Resolution

In Time Off, when an employee is inactive (terminated), the system validates the payout date against the employee’s termination date. If the payout date entered is later than the termination date, the system automatically adjusts the payout date to the termination date and shows the message: “The payout date you entered was after the termination date. The system adjusted the date accordingly.”. After termination:

  • The employee is no longer considered active in the system;
  • Time account payout transactions must occur on or before the termination date;
  • Therefore, the system adjusts the payout date to ensure the transaction remains within the valid employment period.

See Also

Keywords

leave encashment, payout date error, termination date, inactive employee, account payouts, error message, adjusted date, employee profile, self-service, admin, termination, ec, sf, time off, payout request, edit payout request, inactive employee , KBA , LOD-SF-EC-TIM-PYT , Payouts - Self Service, Admin, Termination , Known Error

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions