SAP Knowledge Base Article - Public

3725495 - "System error. Please contact administrator. Error: <entity> changes cannot be saved" error when editing data via OData API

Symptom

You are editing SuccessFactors data using OData API but the API call is failing with an error:

  • "System error. Please contact administrator. Error: <entity> changes cannot be saved"

There is a business rule set for blocking editions on this entity.

Environment

SAP SuccessFactors HCM Suite

Cause

The error is linked to the business rule execution that triggers a warning message when specific conditions are met.

Resolution

Add the parameter warningAcknowledged=true in the OData API request for skipping the rule. More details on warningAcknowledged | SAP Help Portal.

See Also

KBA EmployeeTime Upsert (right before ExternalTimeData upsert) failing with "System error. Please contact administrator"

Keywords

employee time, system error, bulk load, monthly integration, successfactors, employee central, odata, sfapi, warningAcknowledged, take rule, time account changes, error message, upsert failure, data validation, business rules, integration suite , KBA , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , Problem

Product

SAP SuccessFactors HCM Suite all versions