SAP Knowledge Base Article - Public

3725596 - Error: "Party Role Service and Support Team is not active in the Party Schema" when creating a Service Order from a Case

Symptom

When maintaining the Service and Support Team in a case and attempting to create a service order from that case, the error message appears: "Party role Service and Support Team is not active in the party schema. Please contact your system administrator."

If the Service and Support Team is removed from the case, the error does not occur during service order creation.

Environment

  • SAP Service Cloud Version 2
  • SAP Service Cloud and SAP Sales Cloud Version 2

Reproducing the Issue

  1. Open Cases Worklist.
  2. Open any Case.
  3. Remove the Service and Support Team from the case.
  4. Navigate to the Related Entities facet.
  5. Click on "+" and then Service Order.
  6. Verify that no error appears.
  7. Go back to the Case
  8. Add the Service and Support Team
  9. Open the Service Order creation screen again.
  10. Observe the error message: "Party role Service and Support Team is not active in the party schema. Please contact your system administrator."

Cause

The Service and Support Team role has been marked as 'disabled' in the Party Schema for Service Order, but the same role is still passed during service order creation, resulting in the error.

Resolution

When a Service Order is created from a Case, required fields such as Customer, Account, Owner, and Service and Support Team are copied from the source object (Case) to the target object (Service Order).

Keywords

service order, case management, involvement schema, service and support team, party role, error message, role not active in schema, party validation error, case creation, service cloud, error code , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Known Error

Product

SAP Service Cloud Version 2 all versions