SAP Knowledge Base Article - Public

3726030 - 'Approved On' Field Not Visible in View Absence UI for Automatically Approved Absences

Symptom

  • The 'Approved On' field is not visible in the View Absence UI when an absence request is automatically approved.
  • However, the 'Approved On' field is visible in the View Absence UI when an absence request has been approved by a user.

Images/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central > Time Off

Reproducing the Issue

  1. Request an absence on behalf of an employee as a Manager or Admin, which gets automatically approved.
  2. Observe that the "Approved On" field is not visible in the View Absence UI after approval.

Cause

This is expected system behaviour. The 'Approved On' date in the 'View Absence' UI is automatically derived from the workflow itself.

  • Absence requests that are 'Approved Automatically' do not have any workflow, and therefore, the 'Approved On' date cannot be derived.
  • Absence requests that involve an approver will have a workflow, enabling the system to derive the 'Approved On' date.

Resolution

For absences that are 'Automatically Approved', use the 'Requested On' date of the absence as the 'Approved On' date. This is because, as soon as the manager/admin creates the absence on behalf of an employee, the absence gets auto-approved, meaning the date that the manager/admin creates the absence is also the approval date.

See Also

KB Article 3296998 - Absence automatically approved

Keywords

Approved On, approved on, view absence, View Absence, workbench, administer time, absence, leave, time off, view absence UI, automatically approved, approved automatically, auto approved, absence request, approval date. , KBA , LOD-SF-EC-TIM , Time Off , Problem

Product

SAP SuccessFactors Employee Central all versions