SAP Knowledge Base Article - Public

3726171 - Products in a restricted category

Symptom

Products within a restricted category are not visible to non-admin users. The category's visibility is limited to admins, preventing it from appearing in the list for other users. Although products can still be accessed through the search function, they are only visible under the category view if the category visibility is altered to include other users.

Environment

SAP CPQ

Reproducing the Issue

  1. Log into CPQ
  2. Search in catalog for a product which is in the restricted category.
  3. However, by making the category invisible with only permission for admins, it will not appear.

Cause

Previously, there was an incorrect default behavior concerning categories and their permissions. The earlier setup permitted users to search for products regardless of the selected permission group.

Resolution

 

 

Keywords

CPQ, products, category, permission, visible, inactive , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ all versions