Symptom
Duplicate delivery items displayed in the "Delivery items to be billed" popup in the "Create Billing Documents" Fiori app.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the "Create Billing Documents" Fiori app.
- Click "Billing Settings" and turn on the "Choose delivery items to be billed and select quantities" setting.
- Select the delivery and click on the "Create Billing Documents" button.
- Observe that duplicate line items are displayed in the "Delivery items to be billed" pop up.
Cause
One possible reason is that, in the billing due lists table (VKDFS), there are two billing types of billing documents awaiting processing for this delivery (for example:F2 and IV2).
Resolution
This is the standard system behavior as the setting "Choose delivery items to be billed and select quantities" in "Create Billing Documents" Fiori app is not designed for intercompany scenarios.
When our development team initially designed this popup, the focus was on serving customers who utilize a straightforward sell-to-stock process. As a result, this popup lacks some functionalities, for example:
- Delivery-Only Compatibility.
- Batch Item Incompatibility.
- Intercompany Scenario Limitations.
Please take these limitations into consideration when using this feature.
Keywords
delivery items to be billed, create billing document, fiori, duplicate, line items, delivery, billing settings, items, intercompany scenarios, batch items, VF01, popup design, discrepancy , KBA , SD-BIL-IV-2CL , Processing Billing Documents (Public Cloud) , Problem
SAP Knowledge Base Article - Public