Symptom
- Notifications in the offboarding process are sent to the personal email instead of the business email in the system.
- The issue occurs with the following templates:
- Custom offboarding task initiated template
- Document signature task for new hire creation template
- The recipient builder used in the notifications is "Onboarding User ID Recipients Builder".
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
Activate the following notifications in the offboarding process:
- Custom offboarding task initiated template
- Document signature task for new hire creation template
- Configure the recipient builder as "Onboarding User ID Recipients Builder".
- Set the user's personal email as primary and ensure the business email is configured.
- Trigger the offboarding process for a candidate.
- Observe that the notifications are sent to the personal email instead of the business email.
Cause
This is expected behavior.
Resolution
- For the offboarding cancel and other review steps template, the emails are expected to be sent to business emails.
- The offboarding activities templates are using the recipient builders to send the emails.
- As per the recipient builders, if it is role based recipient builder with role as offboardee, emails will be sent to the email ID from users_sysinfo (EC userdata).
- If it is user ID based recipient builder, email will be sent to primary email record from EC, else fallback to users_sysinfo.
- For custom task, the default is user ID recipient builder, so emails are being sent to the primary email.
See Also
Keywords
offboarding notifications, personal email, business email, recipient builder, custom offboarding task, document signature task, email templates, Employee Central, primary email, expected behavior, enhancement request , KBA , LOD-SF-OBX-EML , Notifications , LOD-SF-OBX-OFP , Offboarding 2.0 , Problem
Product
SAP SuccessFactors Onboarding
SAP Knowledge Base Article - Public