Symptom
"Business Role is in a locked collection and cannot be edited." shows when trying to edit business role in app Maintain Business Roles
Environment
SAP S/4HANA Cloud Public Edition
Cause
The issue arises because the business role was exported from the parallel line tenant to the main line tenant via the merge collection but has not yet been imported into the main line tenant. To ensure that changes made in the main line tenant are not overwritten during the import process, the content within the merge collection is temporarily locked for editing. This precaution prevents any loss of data or modifications made in the main line tenant during the time between export and import.
Resolution
To resolve this, please import the Merge Collection into your main line tenant using the Import Software Collections App. Once the import is completed, regain the ability to edit your business roles without any restrictions.
Keywords
Business Role is in a locked collection and cannot be edited, business role, parallel line, merge collection, main line, locked, client 120, maintain business role , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem
SAP Knowledge Base Article - Public