Symptom
- The "Valid To" date in the "Maintain Business Users" user creation section is automatically set to expire 1 year after the user's creation date instead of showing the default date of 31.12.9999 as seen in application "Manage Workforce".
- The discrepancy occurs when creating a new user in "Manage Workforce" and subsequently accessing the "Maintain Business Users" user creation section.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the application "Manage Workforce".
- Create a new user and note that the "Valid To" date is set to 31.12.9999.
- Open "Maintain Business Users" application.
- Click "Create".
- Search for the user created in "Manage Workforce".
- Observe that the "Valid To" date is automatically set to 1 year after the "Valid From" date.
Cause
This is the new system design for creating business users.
Resolution
- The system behavior is by design, where the "Valid To" date defaults to 1 year after the "Valid From" date for security reasons.
- This default value is a suggestion and can be manually adjusted during the creation of a new user in the "Maintain Business Users" creation section.
- Users are encouraged to carefully review and adjust the "Valid To" date as needed during user creation to align with organizational requirements.
Keywords
valid to, date, maintain business users, manage workforce, s/4hana, cloud, user, creation, default, security, valid from, expiration , KBA , BC-SRV-APS-IAM , Identity and Access Management , Bug Filed
Product
SAP S/4HANA Cloud Public Edition all versions
SAP Knowledge Base Article - Public