Symptom
- User is unable to log in to SAP Analytics Cloud (SAC) via SAML Single Sign-On (SSO).
- They get the following error: "It seems you don't have an active account"
- The user exists on both SAC and on the SAML Identity Provider (IdP) side, but still get this error.
- Other users may be able to log-in successfully.
Environment
SAP Analytics Cloud
Reproducing the Issue
- Attempt to log in to SAP Analytics Cloud using SAML Single Sign-On (SSO).
- Observe that the login attempt fails for the user with error message: "It seems you don't have an active account"
Cause
- The SAML Identity Provider (IdP) is sending an incorrect NameID value for the affected user(s).
- For example SAC expects the user's email address in the NameID attribute, but the IdP is returning a different value, which prevents the user from logging in.
Resolution
- Update the attribute/claim mapping in the SAML Identity Provider (IdP) configuration to ensure that the NameID (emailAddress format) returns the user's email address.
- The user should be able to login successfully once the NameID returned by IdP is in the correct format.
Keywords
SAML SSO, login issue, SAP Analytics Cloud, SAC authentication, NameID, SAML Identity Provider, IdP configuration, emailAddress format, claim mapping, login error , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem
Product
SAP Analytics Cloud 1.0
SAP Knowledge Base Article - Public