SAP Knowledge Base Article - Public

3727475 - Change Proficiency Level Scale when Attribute was not Assigned a Scale Previously

Symptom

When using the Change Scale feature in Manage Talent Intelligence Hub, the save button is not selectable when trying to update the scale for an attribute which did not have a scale selected after being created.

Environment

SAP SuccessFactors Talent Intelligence Hub

Reproducing the Issue

  • Attribute created in TIH, with no proficiency level scale selected
  • Attempt to use Change Scale function to add a scale afterwards
  • If only one Proficiency Level Scale exists in the system, or is active, the save button is not selectable

Cause

Known Issue. Occurs only when there is one Proficiency Level Scale in the system that is selectable, and for Attributes which did not have a scale selected during creation of the Attribute Type.

Resolution

This issue is fixed in the 1H 2026 release.

Please tag this KBA to be notified of future updates:

2171560- How to mark a KBA or SAP Note as a favorite and get notified when it is updated - SAP for Me https://me.sap.com/notes/2171560 

Workaround:

  • Define a test/dummy Proficiency Level Scale
  • When using the Change Scale function, select this new scale from the dropdown, this will make the Save button active
  • Then the original scale can be selected and mapped to the Attribute.
  • Note: Scales can be set to inactive but not deleted, if the workaround is used.

See Also

https://help.sap.com/docs/successfactors-release-information/8e0d540f96474717bbf18df51e54e522/216d974d87e04657982ff9d4ad16a466.html

Keywords

proficiency, scale, TIH, attribute type, change scale , KBA , LOD-SF-TIH , Talent Intelligence Hub and Job Profiles , Problem

Product

SAP SuccessFactors HCM Core 2505